productdevbook

Wind Joined Apr 2018 617 followers View on GitHub

Stars
11,037
across 88 public repos
Rank
#2,860
of 323,845 users, top 0.9%
Down 124 places this week

Repositories with 50+ stars

productdevbook's repositories with their overall rank
RankRepositoryLanguageStars
12,459

A powerful cross-platform port management tool for developers. Monitor ports, manage Kubernetes port forwards, integrate Cloudflare Tunnels, and kill processes with one click.

Swift 5,168
30,061

Zero-dependency spreadsheet engine. Read & write XLSX, CSV, ODS. Pure TypeScript, works everywhere.

TypeScript 2,260
100,703

Nuxt 3 best starter repo, Tailwindcss, Sass, Headless UI, Vue, Pinia, Vite, Eslint, i18n, Naive UI

Vue 637
126,744

Zero-dependency barcode & QR code SVG, PNG generator. 40+ formats, styled QR codes, tree-shakeable. Pure TypeScript.

TypeScript 494
176,297

Open-source, self-hosted push notification service built with Vite, Vue 3 & Nitro.

Vue 340
198,180

One unified email API across 18 providers (SMTP, Resend, SES, Postmark, SendGrid, Mailgun, …). Zero deps, RFC 8058 + DKIM ready, edge-first, strict TypeScript.

TypeScript 297
231,889

Motion for Vue is a 5kb animation library for Vue 3 and Nuxt 3. Built on Motion, it's capable of springs, independent transforms, and hardware accelerated animations.

TypeScript 247
398,369

A standalone Nitro module that integrates GraphQL servers into any Nitro application with automatic type generation, file watching, and seamless framework integration.

TypeScript 128
400,912

Type-safe SQL query builder. Zero dependencies, AST-first, hookable, tree-shakeable. Pure TypeScript.

TypeScript 127
413,988

cizgile — Zero-dependency URL slug engine. RFC 3986/3987 slugs, transliteration for 7 scripts, Unicode slugs, IRI ↔ URI, percent-encoding. Pure TypeScript, works everywhere.

TypeScript 122
452,657

Shadcn Tiptap Vue / Nuxt

Vue 109
495,791

Ceviz automatically scans your codebase and detects performance issues that slow down your application:

TypeScript 97
583,149

Driver-based, zero-dependency, fetch-first TypeScript HTTP client. Hooks, retry, redirect security, RFC 9111 cache, RFC 6265 cookies, Idempotency-Key on retry, RFC 9457 problem+json, circuit...

TypeScript 79
600,883

Universal printer language SDK — 9 languages, 9 parsers, 63 cross-compilers. TSC, ZPL, EPL, ESC/POS, CPCL, DPL, SBPL, Star PRNT, IPL. Zero dependencies. Pure TypeScript.

TypeScript 76
600,883

shadcn-style UI components for htmx v4 + Tailwind v4 — 82 web-standards components in 5 flavours (Hono JSX, Jinja2, Go, Phoenix, raw HTML), WAI-ARIA accessible, with a flavour-aware CLI.

Markdown 76
713,808

🧰 Universal, type-safe database adapter layer with a unified API for Drizzle, Prisma, Kysely, Knex, MongoDB, Sumak and in-memory backends

TypeScript 61
809,336

It is a monorepo that includes all end-to-end resolutions. You can create a website, API and mobile application.

TypeScript 52
821,559

Headless components for React, Vue, Svelte, Angular and Solid. Write it once, run it five ways. Work in progress.

51

Among 323,845 users

10k–16k stars: 1,475 users, including productdevbook

Stars along the bottom, and users in each band on a log scale

When they were made

18 repos with 50+ stars, made between 2021 and 2026

Quick stats

Next rank
+4 stars to reach #2,859
Next milestone
+38,907 stars to reach the top 0.1%
Public repos
88, 18 with 50+ stars
Popular repos
11 over 100 stars, 2 over 1k stars
Top repo
port-killer, #12,459 of all repos, 47% of stars
Smaller repos
616 stars from repos under 50

Stars counted Recounted daily Next count around