mathiasbynens
Mathias Bynens Joined May 2009 13,112 followers View on GitHub
- Stars
- 56,553
- across 164 public repos
- Rank
- #263
- of 323,845 users, top 0.08%
- Down 1 place this week
Repositories with 50+ stars
| Rank | Repository | Language | Stars |
|---|---|---|---|
| 1,181 | .files, including ~/.macos — sensible hacker defaults for macOS | Shell | 31,514 |
| 16,968 | A jQuery plugin that enables HTML5 placeholder behavior for browsers that aren’t trying hard enough yet | JavaScript | 3,911 |
| 18,497 | A robust HTML entity encoder/decoder written in JavaScript. | JavaScript | 3,613 |
| 29,353 | Smallest possible syntactically valid files of different types | HTML | 2,313 |
| 30,852 | Subtle and not-so-subtle shell tweaks that will slowly drive people insane. | Shell | 2,204 |
| 35,732 | A regular expression to match all Emoji-only symbols as per the Unicode Standard. | JavaScript | 1,909 |
| 40,510 | A robust Punycode converter that fully complies to RFC 3492 and RFC 5891. | JavaScript | 1,691 |
| 60,100 | Web developer tools | JavaScript | 1,120 |
| 73,856 | A Unicode-aware string reverser written in JavaScript. | JavaScript | 889 |
| 81,447 | Given some data, jsesc returns the shortest possible stringified & ASCII-safe representation of that data. | JavaScript | 802 |
| 112,771 | A robust JavaScript implementation of a UTF-8 encoder/decoder, as defined by the Encoding Standard. | JavaScript | 563 |
| 120,813 | A robust base64 encoder/decoder that is fully compatible with `atob()` and btoa()`, written in JavaScript. | JavaScript | 522 |
| 125,691 | A robust polyfill for the CSS.escape utility method as defined in CSSOM. | JavaScript | 499 |
| 132,237 | jsPerf.com source code | JavaScript | 471 |
| 160,210 | Generate JavaScript-compatible regular expressions based on a given set of Unicode symbols or code points. | JavaScript | 379 |
| 179,601 | Simple PHP URL shortener, as used on mths.be | PHP | 333 |
| 236,688 | A source code transpiler that enables the use of ES2015 Unicode regular expressions in ES5. | JavaScript | 241 |
| 238,376 | A Lua minifier written in JavaScript | JavaScript | 239 |
| 270,364 | A small script that enables you to make typos in JavaScript property names. Powered by ES2015 proxies + Levenshtein string distance. | JavaScript | 205 |
| 306,897 | A JavaScript library for escaping CSS strings and identifiers while generating the shortest possible ASCII-only output. | HTML | 176 |
| 368,455 | A robust & optimized ES3-compatible polyfill for the `String.prototype.startsWith` method in ECMAScript 6. | JavaScript | 141 |
| 381,797 | This Grunt plugin interpolates template files with any data you provide and saves the result to another file. | JavaScript | 135 |
| 391,074 | A polyfill for document.scrollingElement as defined in the CSSOM specification. | JavaScript | 131 |
| 398,369 | Page Visibility shim for jQuery | JavaScript | 128 |
| 411,292 | A regular expression pattern for Java/JavaScript to match all emoji in the emoji-test.txt file provided by UTS#51. | JavaScript | 123 |
| 416,698 | World’s first <details>/<summary> polyfill™ | HTML | 121 |
| 425,075 | Quick demonstration of why `<a rel=noopener>` is needed. | HTML | 118 |
| 499,816 | A robust & character encoding–agnostic JavaScript implementation of the `Quoted-Printable` content transfer encoding as defined by RFC 2045. | JavaScript | 96 |
| 540,170 | A Grunt plugin for compressing files using Zopfli. | JavaScript | 87 |
| 566,057 | regexpu’s core functionality, i.e. `rewritePattern(pattern, flag, options)`, which enables rewriting regular expressions that make use of the ES6 `u` flag into equivalent ES5-compatible regular... | JavaScript | 82 |
| 620,081 | Smooth anchor scrolling plugin for jQuery. | JavaScript | 73 |
| 640,713 | A robust & optimized ES3-compatible polyfill for the `String.prototype.contains` method in ECMAScript 6. | JavaScript | 70 |
| 663,625 | A robust & optimized ES3-compatible polyfill for the `Array.from` method in ECMAScript 6. | JavaScript | 67 |
| 696,148 | Custom QWERTY/AZERTY .keylayout files for use with Apple keyboards | 63 | |
| 704,754 | Kali Linux Docker | Shell | 62 |
| 713,808 | The simplest jQuery slideshow plugin. Evar. | JavaScript | 61 |
| 723,138 | A robust & optimized `String.fromCodePoint` polyfill, based on the ECMAScript 6 specification. | JavaScript | 60 |
| 723,138 | A regular expression to match hashtag identifiers as per the Unicode Standard. | JavaScript | 60 |
| 732,735 | A Grunt plugin for compressing JavaScript and CSS files using YUI Compressor. | JavaScript | 59 |
| 732,735 | Python scripts that generate JavaScript-compatible Unicode data | JavaScript | 59 |
| 774,427 | A robust & optimized `String.prototype.codePointAt` polyfill, based on the ECMAScript 6 specification. | JavaScript | 55 |
| 785,752 | A robust & optimized ES3-compatible polyfill for the `String.prototype.at` proposal for ECMAScript 6/7. | JavaScript | 54 |
| 821,559 | Historical data on COVID-19 vaccination doses administered in Germany, per state. | HTML | 51 |
Among 323,845 users
40k–63k stars: 237 users, including mathiasbynens
Stars along the bottom, and users in each band on a log scale
Where the stars are
Languages
- Shell 33.8k stars, 60% · 3 repos
- JavaScript 18.6k stars, 33% · 33 repos
- HTML 2.8k stars, 5% · 5 repos
- PHP 333 stars, 1% · 1 repo
When they were made
43 repos with 50+ stars, made between 2009 and 2021
Quick stats
- Next rank
- +40 stars to reach #262
- Next milestone
- +122,722 stars to reach the top 0.01%
- Public repos
- 164, 43 with 50+ stars
- Popular repos
- 8 over 1k stars, 1 over 10k stars
- Top repo
- dotfiles, #1,181 of all repos, 56% of stars
- Smaller repos
- 1,003 stars from repos under 50